Hi!

I'm getting the exact same error, but I'm not using Maven (which I know very little about), and I manually get the JARs I need (the ones in the documentation :https://www.elastic.co/guide/en/elasticsearch/client/java-rest/6.1/java-rest-high-getting-started-dependencies.html and https://www.elastic.co/guide/en/elasticsearch/client/java-rest/6.1/java-rest-low-usage-dependencies.html)

But obviously, at least one is missing. Which one is it or how can I know this? Where can I find it?

Thanks!

PS:
If useful, I added the following JARs :
-elasticsearch
-elasticsearch-transport
-elasticsearch-rest-client
-elasticsearch-rest-high-level-client
-elasticsearch-rest-high-level-client-sniffer (All the five are 6.1.3)

-apache's httpasyncclient 4.1.3
-httpclient 4.5.5
-httpcore 4.4.9
-httpcore-nio 4.4.9

-commons-codec 1.9
-commons-logging 1.2

---
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB