-Re: svn commit: r893792 - in /lucene/solr/trunk: example/solr/conf/schema.xml src/java/org/apache/solr/schema/CoordinateFieldType.java src/java/org/apache/solr/schema/FieldType.java src/java/org/apache/solr/schema/PointType.java
Yonik Seeley 2009-12-24, 18:34
On Thu, Dec 24, 2009 at 1:28 PM, Grant Ingersoll <[EMAIL PROTECTED]> wrote:
> On Dec 24, 2009, at 12:42 PM, [EMAIL PROTECTED] wrote:
>> - <fieldType name="location" class="solr.PointType" dimension="2" subFieldType="double"/>
>> + <fieldType name="location" class="solr.PointType" dimension="2" subFieldSuffix="_d"/>
> Shouldn't we demo both?
There are tradeoffs to including all variations of something (that
being schema bloat). These two variants do the exact same thing for
the end user (since the only difference is sub-field naming), so we
should pick one or the other IMO. That's what most people will end up
using. We could include the other variant commented out, but I think
that's overkill too given that we listed an example of each in the
comment for "location".